Single Decatron Clock Issue

More
4 months 1 day ago #13012 by dls
I built the kit and connected the tube. But when I power on the clock the Decatron tube does not spin. I do not even see a dot on the tube.

I checked all the power point and they work. I get 450V as expected. All other power test points give me correct voltages as well.
I have included some photos of the PC board and Tube.
Attachments:

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #13013 by Ian
Replied by Ian on topic Single Decatron Clock Issue
That glow shouldn't be at the bottom of the tube, but at the top under the dome.

Please check the orientation of the wires to the header....

Oh, I see it, the tube is on the board the wrong way round. The large silk screen circle for the tube shows where the tube should go, but the tube is on the other side. :(

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #13014 by dls
Replied by dls on topic Single Decatron Clock Issue
OK, Thanks.
Any suggestions on how I can de-solder the tube? I only have a soldering iron and some solder wick.

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #13015 by Ty_Eeberfest
If you have a jar of flux, or a flux pen, drench your solder wick with flux right before using it. It wicks better that way. Other than that I can't any tips other than to go slow and be persistent.

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #13016 by dls
Replied by dls on topic Single Decatron Clock Issue
Thanks. I'll give it a try.

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #13017 by Ian
Replied by Ian on topic Single Decatron Clock Issue
The good news is that those Bakelite tube bases are tough and the pins are not directly connected to the glass casing of the tube, so it's not a fragile part.

If you damage the tube board while you are working on it, don't worry I have spares and can bung one into the post for you, but as usual the issue is that it will take a week or so to get to you.

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Go to top
JSN Boot template designed by JoomlaShine.com