Single Decatron Clock Issues

More
2 months 4 weeks ago #12786 by ASheep
Hi everyone,

I am currently troubleshooting my build of Ian's Single Dekatron Clock kit, which is striking, but not spinning. Here are some notes from my efforts, frankly I'm stumped at this point! Apologies if this is in the wrong forum section, it's not strictly a Nixie clock, but it is one of Ian's Wemos clock kits.
  • I've checked everything for dry joints or bridges and couldn't find anything. I've reflowed all the main components in the HV and trigger sections of the circuit just to make sure.

  • Open circuit voltages at all test points are within 10% of target value without the OG-4 connected.

  • Resistance values across each stage of the voltage divider are spot on

  • Occasionally it strikes on the rear side of the guides where the wires go into the insulator, other times it strikes on a random main, with some very subtle flickering presumably caused by the guide trying to jump.

  • When a random cathode strikes, the voltage on the 400V header pin is just above 180V referenced to ground. IDX/RTN pins read 70V to ground.

  • When the index cathode is lit the 400V header reads 178V, IDX_IN = 32V, RTN=68V (all gnd ref)

  • When the tube strikes, D6 on the wemos (IDX) is low. Disconnecting the IDX_IN pin from the header forces the arc to jump to the index cathode k0, at which point D6 goes high, so the optoisolator appears to be working.

  • D7/D8 appear to be pulsing as designed, I don't have a scope handy to confirm but the voltage on my multimeter jumps around and averages out around 2V, which is pretty consistent with a pin oscillating high/low. G1/G2 outputs on the headers are fluctuating in a similar way, with the multimeter bouncing between 65-85V referenced to ground. In frequency mode my multimeter is showing 18Hz on G2 and 9Hz on G1, a more useful reading isn't really possible without a scope...

  • Good continuity exists between the tip of each of the dekatron pins and the corresponding solder pad on the main board output header. This should rule out any bad joints between the dekatron/board, board/ribbon, ribbon/header and header/main board.

I'm running it from a 12V 1A power supply, the 5V regulator gets hot to the touch after a while which is not unexpected. I've tried two different plugpacks, both 12V, with the same result. They are both known good adapters, one has run my PV electronics IN14 QTC clock for the last 5 years, and the other runs an Arduino with an Axiris VFD shield as a timer. I don't have any good 9V supplies on hand, I've ordered some but international shipping to NZ is an absolute mess at the moment so who knows if/when they'll arrive!

From my understanding of Dekatrons (which is mostly from Mike's Threeneurons pages) it seems like the voltage isn't getting low enough on the guides to cause the arc to jump. Any help would be much appreciated as I've hit the edge of my knowledge armed only with Ian's circuit diagrams in the construction manual and some limited measuring tools!

Cheers,
Alex

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #12787 by Ian
Replied by Ian on topic Single Decatron Clock Issues
Hi Alex

I have seen this happen a couple of times for completely different reasons.e

1) The tube must be soldered correctly into the tube holder board - it's not possible to just put it in the board without soldering. I have no idea why!

2) Early versions of the PCB for the tube had an error on them - the silk screen was on the wrong side.

If you can show a photo of the tube board, I can figure it out pretty quickly if this is the case.

Ian

Please Log in or Create an account to join the conversation.

Time to create page: 0.081 seconds
Go to top
JSN Boot template designed by JoomlaShine.com