Wemos Numitron runs 1 minute slow (Solved)

More
1 month 1 week ago #12676 by martinmartin
I just finished the 6 digit Numitron clock. All functions work perfectly. I joined my WiFi and all features work fine.
The time zone and interval have been set for my area. After one day the clock runs exactly 1 minute behind.

I tried forcing NTP sync. No effect.

Any ideas?

thanks

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #12680 by Ty_Eeberfest
MOVED to Wemos kit support forum so the right people are more likely to see your post.

Congratulations! You've posted a problem I've never seen before and have no good ideas about the cause.

Just for the hell of it would you please post your exact timezone string?

On the Summary page under Clock Information, does the Display Time match the time on the tubes (a minute slow) or is it the correct time?

I've never installed the RTC battery in my Wemos clock. I figure I don't need itbecause the clock is always here on my desk, on WiFi, so the NTP keeps the time set. If it loses power it hits NTP as soon as power comes back. Can't see a need for the RTC. Might be worth a try to pull your battery in case there is some weirdness happening with RTC vs. NTP. I've not heard of any issues like that but couldn't hurt to check it.

Under Current Status, what Version is displayed? I've had mine for well over a year. It is Version 6. If yours is running a higher version I guess there could be a new bug that I don't know about yet.

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #12681 by Ty_Eeberfest

martinmartin wrote: After one day the clock runs exactly 1 minute behind.


One other thing: what about after 1-1/2 or 2 days? Is it still exactly 1 minute or is it progressively losing time? IOW is it a consistant 1 minute offset from the real time?

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #12682 by martinmartin
ESP Numitron Clock
Summary
Configure Time Server
Configure clock settings
Utility
Current Status
Name Value
WLAN IP 192.168.1.150
WLAN MAC 48:3F:DA:48:65:36
WLAN SSID -FOGS-
NTP Pool pool.ntp.org
TZ PST8PDT,M3.2.0,M11.1.0
Last NTP time 2021,8,11,18,44,16
Clock Name ESP_486536 (http://esp_486536.local)
Uptime 3 d 9 h 30 m 56 s
Last time update 42 m 47 s ago
Time before next update 1 h 18 m 13 s
Version 6
Found I2C slave at 104
Clock information
Name Value
LDR Value 602
Digit brightness % 63.54
Motion Sensor Not installed
Time Source NTP
Display Time 2021:8:11 19:27:4
Real Time Clock Installed
RTC Time 2021:8:11 19:27:4
Impressions/Sec 90
Total Clock On Hrs 7 d 23 h 38 m 0 s
Total Tube On Hrs 7 d 23 h 38 m 0 s
ESP8266 information
Name Value
Sketch size 491696
Free sketch size 2650112
Sketch hash ff023d750033e4be14de5a615bb1b250
Free heap 22408
Boot version 31
CPU Freqency (MHz) 160
Flash speed (MHz) 40
SDK version 3.0.0-dev(c0f7b44)
Chip ID 486536
Flash Chip ID 164020
Flash size 4194304

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #12683 by martinmartin
When it first joined the WiFi it was fine. The next day is lost a minute.
Funny it's exactly one minues.

the time zone string is
PST8PDT,M3.2.0,M11.1.0
and the update interval is 7261

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #12684 by Ty_Eeberfest
You have the same firmware version that I do.
Your timezone string looks fine.
There's nothing on the Summary screen that looks wrong.

Questions you haven't really answered (TL;DR)
1) Is it always exactly 1 minute or does it drift?
2) If you refresh the Summary screen and immediately check the Display Time and RTC time do they match the time on the tubes or is there a 1 minute offset?

Ignore what I said before about pulling the RTC battery. If you want to disable RTC as a test you need to remove the RTC chip from its socket.

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

Time to create page: 0.109 seconds
Go to top
JSN Boot template designed by JoomlaShine.com