Flickering columns on Nixie clock

More
4 months 5 days ago - 4 months 5 days ago #11277 by Marc
Good afternoon,

I build my first Nixie clock. The All in one clock, rev 4.



It has been a nice build. But i did not like the column with only one neon bulb in it.

So i placed two neons in one column in serie. But in low light conditions the columns start flickering a bit. Both columns has a 80k resistor on R38 and R39 on the pcb.

The specs of each neon bulb are:
90 V
0.55ma

Does anyone know why this is happening?
Attachments:
Last edit: 4 months 5 days ago by Ian. Reason: Added video zip

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #11279 by Ty_Eeberfest
You can try a bit lower value resistors without blowing anything up. My math, using your specs, says the resistors should be 72.7K. A close standard value would be 68K.

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #11280 by Ian
I don't have experience of running neons in series - I'm not sure if that works fine. I have always run them in parallel in the past.

The reason that I think it might not work, is that neons are high volume, low price things with wide tolerances. I can imagine that if they are not well matched, one neon starves the other. I'm not sure, I'm guessing.

Also, in the clocks, we are running with PWM, which is also a bit of a challenge for neons. They don't always ignite predictably.

Are these neons all the same, or are they mixed types?

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #11281 by Marc
I tried yesterday without any resistor. But unfortunately the same thing is happening but with a brighter light bulb which’s starts flickering:

This is how its behaving with 80k resistors:

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #11283 by Ian
Try them in parallel? With a 180k resistor on each?
The following user(s) said Thank You: Marc

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #11284 by Ty_Eeberfest

Ian wrote: Try them in parallel? With a 180k resistor on each?


I didn't notice that he said he's running them in series. I agree they need to be in parallel. I'm surprised they light up at all in series. When I suggested 68K I was thinking of 1 resistor feeding 2 parallel neons.

Look into it later when the dust is clearing off the crater.
The following user(s) said Thank You: Marc

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.098 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com