Nixie Clock Build GN-4, Proximity Sensor, GPS & Dekatron

More
9 months 4 days ago #12832 by mclegg
Ty
I cant thank you enough for your help during this build. Without your help it would have had magic smoke written all over it.
Now that the physical build is complete I fired everything up and most things seem to be working:
- All Nixies work fully
- The RGBs work
- The switch and LDR work
- The WiFi module works
- The Neon works (kind of)
- Not sure if the PIR works, as it hard to tell at this stage - this I will worry about last.

I have set it up on the network which was really easy and have logged into it to set it up. I have noticed however the lack of options that I can see, compared to the manual. Please see the attached images.

I haven't been able to setup the Time Server as it only has a URL, not the string settings as in the manual. I am in NZ, so trying to understand what this URL or string should be is a little difficult. Do you know what this URL/string should be or where to find this information?
There are also missing PIR settings (from what I can tell) among others.
There looks to be a utilities tab that is also missing.

I assume this is the version of the firmware I have loaded? The Wifi manual suggests you can update it automatically online, however I may be on an earlier version and it may not allow it? To be honest, Im not sure which version of Firmware on the IC and which version on the WiFi I am running. Can this be seen on the Summary picture attached?

The other interesting thing I have found is to do with the neon, of which I am only using one.
When I first tested it during the build it was ticking correctly, now however it looks to be ticking backwards.
I would describe this as:
Ticking normally: Pulse/Cut in and fade out.
Ticking Backwards: Fade in and Cut/Pulse off.
It also seems to get confused. For example it will pulse in and fade out a bit, then change to fade in and cut off, while sometimes just fading in and out (often when changing between the previous two modes). Do you have any idea what could be the cause of this?
I note that the neon changes with the LDR and dimming of the Nixies. When its dark the Nixies are dimmer and the Neon is almost non-existent and not really ticking at all. When I put light on the LDR the Nixies become bright and the Neon comes brighter. This I would expect however.

Sorry for the novel above. Any help you could provide would be appreciated.

Cheers,
Attachments:

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago - 9 months 3 days ago #12833 by Ty_Eeberfest
Most of what you described can be attributed to older firmware versus new manual. You can probably run just fine with the older firmware but updating to the latest would give you the missing features including the rather useful Over-The-Air updating. I don't find myself updating clocks very often but when I do it's nice to have the OTA.

EDIT: The OTA feature, in its present state of development, provides OTA updating of the ESP WiFi module but NOT the clock controller. So you still need physical access to the clock to update the controller.

Remember: you have to update the clock controller and the ESP at the same time. If you don't you end up with a version mismatch that can cause all kinds of troubles.

The time zone business is also a matter of versions. Your older version uses "tz database" aka "Olson" time whereas the newer versions use the more familiar NTP. I believe the manuals now talk only about NTP. Here is the URL to use for getting NZ time from Ian's tz server:
http://tzs.nixieclock.biz/getTime/Pacific/Auckland
For a complete explanation of tz / Olson time and a listing of all the various timezone URLs try here:
en.wikipedia.org/wiki/Tz_database and
en.wikipedia.org/wiki/List_of_tz_database_time_zones

Should you decide to update to the newest NTP-capable firmware, your Posix-style timezone string will look like this:
NZST-12NZDT,M10.1.0/2,M3.3.0/3
The module will automatically use pool.ntp.org without you having to do anything besides setting the timezone string.

Regarding the neon separators, I've seen something similar happening before. Neon lamps in general are not real happy being dimmed and there's a lot of variation between types (or even batches) of neons. As you mentioned, using LDR in a dark room exacerbates things. As an added complication the striking voltage of neon lamps inherently increases as the surroundings get darker.

Increasing the value of LDR Min DIm, or turning off Use LDR completely, may help but the obvious side effect is that the tubes don't dim as much. Sprinkling uranium ore on top of the clock will also help (just kidding, don't try it, but it is true that low level radiation improves neon devices' ability to strike in the dark, thus Kr-85 or Ar-42 gas being added to some Nixie tubes during manufacturing). Or you could do as I did and modify the firmware to make the neons blink instead of pulsate.

Look into it later when the dust is clearing off the crater.
Last edit: 9 months 3 days ago by Ty_Eeberfest.

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago - 9 months 3 days ago #12834 by mclegg
Thanks For that.
I will look to update both and see how I go.

Since then however, I had magic smoke this morning.
The clock ran fine last night for a couple of hours.
Took it to work with me, used another power supply which was 12v. It worked for about 10min then I noticed all the Nixies and RGBs flashing on/off together, on for 1/3 of a sec and then off for a 1/3 of a sec or so. Becoming more erratic. By the time I reached around to turn it off the magic smoke had appeared. Taking it all apart, the IRF640N looks to be fairly tarnished and black.

I let it all cool down, tried it again with a 9v power supply instead - as this is the only thing that changed from home. It looks like the low voltage stuff all works, RGBs are on, the WiFi unit lights up. I tried a factory reset, however after a few seconds the IRF640N gets VERY (cant touch/burn you) hot.

Any idea why this would happen?
I assume I will need another IRF640N. Looking online there are lots of variants, however I assume that if the start of the product code is IRF640N I should be fine? For example there are some codes such as IRF640NPBF.

Any input would be appreciated.

Cheers,
Last edit: 9 months 3 days ago by mclegg.

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago - 9 months 3 days ago #12835 by BS_Jim
The problem you had was probably caused by switching power supplies and not doing a factory reset to calibrate the MOSFET to the new supply. MOSFET's have a positive temperature coefficient and conduct more as they get warmer leading to smoke signals. You should always run a factory reset with a new power supply.

I don't think the suffix letters mean a whole lot more than different package configurations but Ty will let you know if there's something to stay away from. May I suggest you buy a couple spares because they're cheap enough.
Last edit: 9 months 3 days ago by BS_Jim.

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago #12836 by mclegg
Thanks, I was not aware of the need to factory reset for a new power supply.
Hopefully this is all that has been damaged.

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago #12837 by BS_Jim
Depending on how quick you shut it down, there's always the possibility that the inductor got too hot and shorted a few turns. You could order a spare inductor or two when you order the FET(s).

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.107 seconds
Go to top
JSN Boot template designed by JoomlaShine.com