WiFi module not working

More
4 months 1 day ago #12151 by hunters628
Hey guys, I have a classic rev6 that im trying to get set up. I bought the kit about 2 years ago and im just getting around to making the clock if that makes a difference. The problem Im having is with the wifi module. I can sometimes see the wifi network pop up but my devices will rarely connect to it. the rare time it does connect i do not get a captive page nor am i required to put in a password like the manual states. I have gotten in by putting in the IP address a couple of times but of those times my home wifi network has only appeared in the list one time. I tried to sign into my home network but my device lost connection to the module. In reading other posts i saw this is how it should work and will then connect, however, my module stays in AP mode and does not change. Im not sure what the issue is here. Could it be a bad wifi module? Ive tried on 4 different devices and i get the same results across all of them.
Thanks.
Hunter

Please Log in or Create an account to join the conversation.

More
4 months 16 hours ago #12153 by Ty_Eeberfest
I think the module is physically okay but I'm not sure about the firmware. A lot has changed in 2 years, for example I think the captive portal stuff was added since then. Do you have the means to re-program the module and the clock board with new firmware?

From what I can remember of the older firmware versions you had to connect to the module while it's being an AP and then browse to 192.168.4.1 with most any web browser. That would get you to a page (not sure about needing password here) with a few links across the top (which may be so small you can easily miss seeing them if using a phone) , one of which took you to a page where you had to type in the name (the SSID) and password of your network. It would then try to join your network and if it succeeded it would shut off it's AP (thus kicking you off). It would pick up an IP on your network from your AP/router and then you're kinda on your own to figure out what IP it got.

Once your device is back on your own network and you've figured out the IP of the clock you should be able to just browse to that IP and see the clock's web pages.

All-in-all the newer firmware would be the better way to go but you need to be able to compile code for ESP-01 and for Uno (must upgrade clock and WiFi at same time) and then upload it. That means you need Arduino IDE with the right board files for ESP and Uno. Also an Uno or clone with socketed CPU. Since the clock has no USB you pull out the chip and stick it in an Uno to program it. Also need the usual "dongle" device for programming ESPs.

New firmware is at:
bitbucket.org/isparkes/nixiefirmwarev2/src/master/
You'll need the "FirmwareV2" and "WifiTimeProviderESP8266" repos and probably "Libraries" too (depending on your existing Arduino IDE setup).

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
4 months 15 hours ago #12154 by hunters628
Replied by hunters628 on topic WiFi module not working
Unfortunately I have no way to reprogram the board or module. Is there someone I can send it off to for reprogramming?

Please Log in or Create an account to join the conversation.

More
4 months 5 hours ago #12155 by hunters628
Replied by hunters628 on topic WiFi module not working
Ok, I for sure need an update. I got my module connected to wifi and it uses the old style time server setup that doesnt appear to work anymore. I found it in the archived wifi rev1 v2 manual so I know its out of date. Can I purchase the update kit on the nixieclock.biz store to fix this issue?

Please Log in or Create an account to join the conversation.

More
4 months 5 hours ago #12156 by Ty_Eeberfest
This is easily fixed. I'll email you in a few minutes.

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #12157 by Ian
Replied by Ian on topic WiFi module not working
This is a recurring theme - There's a fairly easy way of setting up a programmer if you have an Arduino laying around, or have one the $1 ESP modules (which are not quite programmers, but are pretty close), it's not hard when you know how. But that's the point - it's not really an obvious thing and you have to know how to go about it.

I'm thinking of offering programmers for the ESP and the 328P to try and enable people over this initial part of the problem, which is pulling the few bits of hardware together. Do you think that would have value?

If you run into a dead end on the programming, I can send you a new module, but that will be in January, as I have stopped for XMas now, and am in another part of the world from the office.

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.114 seconds
Go to top
JSN Boot template designed by JoomlaShine.com