No high voltage, no help from the seller...

More
11 months 2 weeks ago #10748 by wiktorsam
No eBay APP ID défined in Kunena configurationSome time ago, i bought 4 digit wemos nixie clock from ebay:

When it arrived and i found some free time i soldered everything, but the clock is not working. There is no 170v - i get only 6,5v on the test pins and irf640 goes hot. I have checked everything three times and it looks ok. I've got experience with soldering so i don't think that problem is relaed to improper assembly of the kit.

I wrote message to the seller and he answered me:

Hi, did you check the HV at the end of that part of the construction? Was there HV at that moment?

Things to check:
- Take out all other components from sockets (even 34063)
- Power on and see if the MOSFET gets hot - it is does the problem is with R3, D2 or Q1
- Check that the 2N3906 is the right way round and is not a MPSA42 (Q1)
- Check that the gate resistor R3 is correct and is making contact
- Check that D2 is facing the right way (silver band into the square hole)
- if you get replacement 34063, you can try one of those: normally they are very robust and don't break
- Are all components C13, D3, R4, R5, L1, RV1, Q1, U4, R3 and D2 installed? Install C9 if it is not installed. I know that the other parts D1, R1 and Q2 are installed, because otherwise Q2 will not get hot.


I checked things that he told me and after taking out all components from sockets irf640 stays cool. 2N3906 is the right way round and is not a MPSA42. 2n3906 is fine, i checked it with my multimeter. R3 is correct and making contact. d2 is facing right way. I tried replace 34063 but it did not change anything. All components are installed. C9 is installed...

I answered to the seller, but he did not respond.... So can anyone help me? I use 9v power supply, i have 5v output on test pins, only HV is not working. I m pretty sure that everything is mounted correctly.



Attachments:

Please Log in or Create an account to join the conversation.

More
11 months 2 weeks ago #10749 by Ian
Ebay is a terrible place to solve these things: The pictures are useless (because EBay reduces the size) and there is no threading of replies. Please deal with technical issues here.

Do you have an oscilloscope? If so, we can check some things. If you do not, we will have to take things slowly.

I did ask the question: "Did you check the HV at the end of the HV step? Did it work then?", but I don't think I got an answer.

Please Log in or Create an account to join the conversation.

More
11 months 2 weeks ago - 11 months 2 weeks ago #10750 by Ian
What is the voltage at the HV test point with the components out of the sockets? (Also the 34063)?

So here are the things we know:
- With the 34063 out of the socket, the MOSFET is not conducting: OK.
- With the 34063 in the socket, the MOSFET is conducting: NOK

Can you check the 680pF timing capacitor with the 34063 not in the socket? You can check this across pin 3 and 4 of the 8 pin socket.

Attachments:
Last edit: 11 months 2 weeks ago by Ian.

Please Log in or Create an account to join the conversation.

More
11 months 2 weeks ago #10751 by wiktorsam
No i did not. It is my mistake, i was thinking that kit is fine, so i soldered everything in one go. After that i tried to run kit without nixie tubes and checked voltages - 5v was ok, but no 170 at all - only get 6,5v.
I don't have oscilloscope.

Please Log in or Create an account to join the conversation.

More
11 months 2 weeks ago #10752 by Ian
OK, no worry, as long as we keep the other components out of the sockets at the moment, we can still fix it.

As you can see, the circuit is not complex.

Do you have a signal generator by any chance?

Please Log in or Create an account to join the conversation.

More
11 months 2 weeks ago #10753 by wiktorsam
Thanks for your answer. Im in my work now so i have only smal multimeter without capability of checking capacitors. At home i have big multimeter, and "MG328 Multifunction Transistor Tester Inductor Capacitance Resistance ESR Meter" only - no other testing stuff :(. So i can check this capacitor later.
Without 34063 in the socket i have 8,2 V at HV testing points.

Please Log in or Create an account to join the conversation.

Time to create page: 0.181 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com