I think I cooked one of the MOSFETs

More
1 month 1 week ago #11565 by luke.jaeger
I just put together an Arduino all-in-one clock and it worked fine for a couple of days. But today one of the MOSFETs (the one farther from the power socket) got super hot and started to smoke -- I quickly yanked the power plug, and now nothing at all happens when I plug the clock in!

This was the first time I ran it with the photoresistor attached ... I don't know if that has anything to do with the problem. The directions were a little ambiguous but it seemed like the LDR was supposed to be connected to the LDR pin and to GND? Anyway, that's how I set it up, and it seemed like the ambient light control was working.

Anything I should do other than replacing the cooked MOSFET?

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago #11573 by Ty_Eeberfest
For some reason I didn't see this until today. Sorry about that!!

First of all I really doubt the LDR had anything to do with this unless you somehow shorted something else when you installed it.

This is important: when the MOSFET began smoking did the clock appear to still be working in any way, e.g. tubes still lit or LEDs still blinking? If not then there's a chance the Atmega controller quit. I'm rather suspicious that this is what happened because you say the clock is now totally dead and a bad MOSFET alone will keep the tubes from lighting but everything else (LEDs, WiFi if present, etc.) would still work. I've heard of this happening to a couple people, where the controller quits running and leaves the HVD output (Pin 15) high. If that happens it's guaranteed the MOSFET will burn because it's left on instead of being pulsed.

I suggest you remove the burnt MOSFET. Cut off its pins just below the body of the part for now rather than trying to unsolder. The power it up and see if you get any LED action or other signs of life. If not, then the controller, or maybe the crystal and the 22pF load caps, may be bad.

You could also check the inductor L1 (right next to the MOSFET) with an ohm meter. It should have just a few ohms of DC resistance but not zero.

That's all I can think of for now...

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #11579 by luke.jaeger
Run like a villain, let the good times roll.

Yes, the LED's power up with the burned MOSFET removed. I replaced the MOSFET and now it's ok.

I might have caused this barbecue by wiring the button switch wrong. Some of the wording in the Construction Manual is a little ambiguous: "The switch connects to ground when closed" -- well, that's clear enough but the next sentence gave me the impression that I should connect VCC to the NC pole of the switch. When I looked at the schematic I realized that of course this was wrong. Maybe that's what cooked it?

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #11580 by Ty_Eeberfest
Nice to see that someone gets the Iggy reference!

I looked at that section of the manual. What it's saying is "you don't need to add a pull-up resistor on the button because we're using the one that's in the Atmega". I suppose that sentence is there to head off questions from people who see a switch that pulls an input to ground and automatically think a pull-up is needed (which is a reasonable thing to think if not familiar with microcontrollers with internal pull-ups). Anyway...

I'm not sure how miswiring the button could kill the MOSFET but I suppose if a short was created that dragged down the VCC (+5) rail badly enough to to confuse or halt the Atmega almost anything could happen.

Bottom line is that, assuming the inductor (etc.) is good, the thing that causes MOSFET burn-ups is having it stay on for more than a few milliseconds at a time. If the Atmega is "disturbed" it could - and has in a few past cases - leave the MOSFET on continuously, leading to meltdown.

Having replaced the MOSFET it might be a good idea to force a factory reset (hold down the button while powering up) so the firmware can do its MOSFET characterization / calibration routine with the new part.

Look into it later when the dust is clearing off the crater.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #11581 by Ian
I don't think anything you did has caused the problem, there have been a few problems with component supplies recently - most important is that a batch of inductors have come in with wide tolerances, and that causes the MOSFET to get sweaty.

So, what's happening here is that the inductors should have a tolerance of 10%, but I'm starting to see that they are really 20% or more. When it's +20% that's fine - an inductor of 120uH will work just great. When it's -20% that is a problem: the 80uH doesn't have enough impedance to stop the MOSFET saturating and it gets hot. I'm still not sure why this suddenly goes into a death spiral.

The other alternative is like Ty said, that the controller is disturbed. The disturbance that could cause this is clock circuit troubles, which causes the controller to stop momentarily while the MOSFET is on. I have seen something like this in noisy environments with crystal circuits which are at the edge of stability. A good test is touching the crystal can with your finger: If it causes a reaction, it is a good idea to ground the crystal can.

If it's running again, please keep a good eye on it - either it was a bad MOSFET (prpoblem is solved now), or a bad inductor (the problem is waiting to happen again) or a noise problem (problem is waiting to happen again).

Have a poke at the crystal can, and if the display flickers, consider grounding the can. On the newest boards there is a grounding hole next to the can - however take a careful look at is, because on the first version with the grounding spot, the hole was not attached to the ground plane. Doh!

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #11582 by luke.jaeger
Thank you gentlemen!
I did a factory reset and the clock is now running. The MOSFETs are still rather hot, but not hot enough to melt solder like before -- I can touch them for maybe a second. I'm going to stick a couple of heat sinks on them to see if that helps.
My power supply is a 12V laptop brick. I could swap in a 9V supply if that's better.
Ian, I assume 'crystal can' means Q2?

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.175 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com