IRF840 melted, but with a 3 day delay

More
9 months 2 weeks ago #10358 by MishuD
Hello. I had some issues with the clock, using a 9V 1A power supply. I assumed it was cheap, didn't manage to provide sufficient power, and it burned. I replaced it with a 12V 2A power supply, and it worked. The IRF never got hot, the PWM is set to 150, to not strain it, it ran like a charm for 3 days. This morning, i woke up to the smell of PCB burn. The clock has stopped, the PCB around the IRF is charcoal and the IRF is blown beyond repair. What the hell happened that it took a 3 day delay to ruin it? I regularly checked it before, after the previous incident, and it kept cool

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #10359 by Ian
Can you tell me which clock type this is?

I have had one once have a thermal runaway, but that clock type is an old one. However, perhaps it is the same thing,

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #10361 by MishuD
It's the Arduino Uno clock

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #10364 by Ian
OK, then it's not the same problem. The one I had a problem with had a very thin trace for the gate drive that went round the other two pins, with two little spacing. This not the case on your board where there is plenty of room.



I can see a few possible reasons:
- The Arduino stopped and held the gate high.
- The MOSFET was just faulty and failed
- There is something in the adjustment of the PWM settings that does not work as expected - people don't usually change these

I can offer you a replacement of any of the parts you wish, or a replacement kit, or if you prefer I can repair it for you.
Attachments:

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #10365 by MishuD
Thank you very much for the quick response. I have already ordered a new MOSFET, speaking of which, i noticed that on the instructions, it uses a IRF740, while i have received an IRF840. I have ordered one of each, and was curious which one do you recommend (again, my IRF840 has burned to a crisp). I'll replace the MOSFET first, and use a high-quality 9V 1A power source, see if it works, if not, i'll have to rewire the thin copper line going from pin1 of the MOSFET, as it's currently exposed (the heat burned the board around it) but looks intact. IF that doesn't work, i'll replace the condensers too, maybe those burned. If all that fails, i'll see about a replacement. I don't want to bother you with a new board, seeing as it might just be a faulty component, and if i can salvage it, i will.
Thanks again for the response,
MishuD

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #10367 by Ian
So, the MOSFET story is a long one.

Now the preferred is an IRF640. The very first ones were IRF740, and for historical reasons and safety reasons we used in the recent past IRF840.

So the historical reason is that the HV generator used to overshoot the target voltage by a lot, so IRF840 was safe. Also the IRF840 is really tough - it takes a LOT to hurt it. Now the software has been corrected and there is no need to have the higher voltage.

The IRF 640 has a lower Rds value and does not generate so much heat.

I'm sorry that it went wrong. The offer of spare parts is always there if you need them.

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.266 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com