WiFi time provider with NTP support.

More
1 year 4 months ago #9740 by MikeS

Stackerlee wrote: Strange. I get this: (correct local time is 16:55 CET)
Current time source NTP
Current time Wednesday, 13-Feb-2019 15:55:57 UTC

It's getting the correct time, but looks like it's not applying the TZ string - it's reporting as UTC and not CET.

Try resetting the WiFi config (Utility/Clear WiFi config and restart module), and then set things up again. I increased the size of the storage for settings over what Ian originally had, and it might be good to start fresh. You'll have to go back and configure with WiFi module from scratch (connect to SSID NixieTimeModule, go to http://192.168.4.1, etc).

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9741 by MikeS

Ian wrote: In the V1 repository, there is a branch with WiFi Manager as the way of setting the initial login up. I guess that thing will be the next to be included.

??? My code should work with both V1 (assuming I can get Stackerlee working) and V2 clocks, so the current WiFi code for V1 clocks can simply go away.

Ian wrote: However, I'm starting on the V2 code on a new branch. I'm using version v355mjs.9. Is that the right one?

I just updated the package to v355mjs.A. Any of the previous links should point to it.

I added a DNS server when in softAP mode, so people don't have to remember (or look up) 192.168.4.1. When connected to the softAP, you can simply open nixie.com (or any name really, it wildcards everything). I also changed it so all the items on the clock config page can be entered. It used to be if, say, Scrollback was off, you couldn't turn it on and enter Scroll steps. You had to turn it on, Set, then go back in to configure steps. That seemed awkward, and allowing the setting of things which aren't used shouldn't hurt anything.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9742 by Stackerlee

MikeS wrote: Try resetting the WiFi config (Utility/Clear WiFi config and restart module), and then set things up again. I increased the size of the storage for settings over what Ian originally had, and it might be good to start fresh. You'll have to go back and configure with WiFi module from scratch (connect to SSID NixieTimeModule, go to http://192.168.4.1, etc).

I've done this and it still SOMETIMES reports UTC (wrong), sometimes CET (correct) after power cycle. So it's inconsistent.
Where can the aforementioned v355mja.A be found?
Thanks!

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9743 by MikeS

Stackerlee wrote: I've done this and it still SOMETIMES reports UTC (wrong), sometimes CET (correct) after power cycle. So it's inconsistent.
Where can the aforementioned v355mja.A be found?
Thanks!

OK, I changed it so we set the TZ string each time we get time. Try it now (now at .B, any previous link in this thread will get the latest version).

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9744 by Stackerlee
Splendid!
Seems that did the trick.
Haven't been able to reproduce the problem since the update.
v355mjs.B

Thank you!

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9750 by Ian
Hi Mike

do I have your permission to distribute the code to others, for commercial purposes? I hereby ask your permission to include your modified code as part of the standard software, so that I am able to pass on to others under the CC-BY-NC license. The license requires me to ask your permission before doing so. Are there any other provisions you wish, other than attribution?

Regards

Ian

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.185 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com