wifi time module - could not configure clock with browser

More
3 years 1 month ago #7584 by Marcel
Hi,

I have just assembled my "Arduino IN-14 Nixie Clock v45" and the "WiFi Time Provider v1 for Arduino Nixie Clock".
It seems to working perfectly, the module connects to time server and the blue led flashed slowly. The time is correctly set.

The problem: I could not configure anything with the browser.

for example this url who should set 12h24h mode to 12h don't work

http://192.168.1.37/clockconfig?12h24hMode=12h&blankLeading=show&useScrollback=off&suppressACP=off&dateFormat=2&dayBlanking=0&blankFrom=&blankTo=&fadeSteps=50&scrollSteps=4&backLight=5&redCnl=15&grnCnl=0&bluCnl=0&cycleSpeed=10

an idea ?

marcel

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7588 by Ian
Hi Marcel,

The request url looks right, so is the problem that you see tjhe configuration window correctly, but when you press "set" nothing on the clock changes?

How long are the wires between the clock and the WiFi module? I have experienced some problems if these are longer than 5cm.

Regards

Ian

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7605 by Marcel
Hi Jan

Yes, exactly, nothing changes on the clock when I press "set".
The wires where 10cm long... I shorten them at the maximum ( ~1cm. see photo), but it's always the same.
may be it's a software version problem?
I joined also "summary" printscreen.

thanks
marcel
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7612 by Ian
Hmmm, tricky...

The WiFi module sees the clock "Found I2C slave at: 104".

It can take up to a minute to get the first update, but I guess you have tried leaving it a few minutes?

What is the clock firmware version?

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7615 by Marcel
Clock firmware version shows "00 45 07"
I must disconnect wifi module and then it shows it at boot...

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7616 by Marcel
a dumb question: I don't use the real time clock module...
Must I connect it to the i2c bus ?

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.198 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com