170V and Ground shorted on Rev2V45a

More
3 years 4 months ago #7372 by D33R
I recently purchased a Revision 2 Version 45a board from Ian's Nixie Clocks. I have assembled everything except for the tubes as I am waiting for some extension leads to make them long enough to go over the RGB LEDs. I plugged it in quickly after installing each RGB LED to make sure they all were working, but the last time I did it a little ball of solder had fallen and become lodged between 170V and GND on SV1, shorting them together. This sparked when I plugged it in and I unplugged it as quick as I could. Now none of the RGB LEDs work. At SV1, there is 4V-5V at VCC, and there is only about 5V at the 170V, and the IRF840 Mosfet gets hot quickly when plugged in. This is the first project like this I have ever done, so I'm completely lost as to where to start checking for damaged components.

www.nixieclock.biz/Downloads/NixieClockI...ionManualRev2V44.pdf
(That is V44, but that's the most recent Rev2 manual he has uploaded)

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #7374 by Ian
Oh, that's really unfortunate, but don't worry, we'll get you working again.

My suspicion is that the MOSFET has taken a hit, and possibly the controller as well. Let's see if we can narrow it down and I'll send you replacements.

Step 1: Take out all the socketed components (opto-isolators, controller, K155) and try to power up again. The RGB LEDs might glow a little, but that's due to leakage. Check if the MOSFET gets hot. If it does get hot, the MOSFET is dead and you need to remove it from the board.

Hint: Snip the "head" of the MOSFET off before you attempt to remove it, then remove the pins one at a time. Much less stress for the PCB and the solderer. ;)

If the MOSFET doesn't get hot, it looks like the controller that is at fault.

BTW, thanks for pointing out that the manual was not displayed on the dox site. Fixed now.
The following user(s) said Thank You: D33R

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #7375 by Ian
Just FYI: I moved the topic to the support forum rather than the general forum.

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #7376 by D33R
With everything unplugged the MOSFET stays cool. Plugging in the controller makes it get hot. Unfortunately I also broke my K155 when I removed it, so I will need to buy a new controller and K155 from you. Let me know when you can set up that transaction. Thanks!

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #7377 by Ian
OK, I'll send a new controller and K155ID1. No charge, support is included the price. :)
The following user(s) said Thank You: D33R

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #7378 by D33R
Thanks! I appreciate it!

Please Log in or Create an account to join the conversation.

Moderators: AccutronTy_EeberfestIan
Time to create page: 0.169 seconds

Search

Tube Suppliers

Go to top
JSN Boot template designed by JoomlaShine.com